Question

What are the system requirements to use BusyBeePad? Which web browser should i use?

Answer

For a fantastic BusyBeePad experience we recommend that you use the latest version of Google Chrome or Mozilla FireFox.  These are really cool, safe and fast browsers for both Mac and PC.

BusyBeePad also works great with the latest version of Safari and Opera.

Internet Explorer is a bit of a problem browsers sometimes with some technologies. BusyBeePad should be OK in IE9. However in IE8 and earlier version there are issues that we're working on.

Go back to FAQ's | Go to BusyBeePad